`
caoruntao
  • 浏览: 468574 次
  • 性别: Icon_minigender_1
  • 来自: 西安
社区版块
存档分类
最新评论

动态规划:Square Coins

 
阅读更多
问题描述:
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=172), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.

There are four combinations of coins to pay ten credits:

 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2

10

30

0

Sample Output

1

4

27

 

问题分析:

二维数组w,其中w[i][j]表示:使用<=i并且>=1的整数序列{1...i}的变系数平方和等于j的多项式个数。

构造递推式:w[i][j] = sum { w[i-1][j-k*i*i] },其中k=0,1,... j-k*i*i >= 0,这个式子的意思是,使用<=i-1并且>=1的整数序列{1...i-1}的变系数平方和等于j-k*i*i的多项式个数的和,这个和等同于,使用<=i并且>=1的整数序列{1...i}的变系数平方和等于j的多项式个数。因为整数序列{1...i-1}的变系数平方和多项式再加上k*i*i就是整数序列{1...i}的变系数平方和多项式。

 

package com.iteye.caoruntao.zoj;

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

/**
 * @author caoruntao
 *
 */
public class SquareCoins {

	private static int w[][] = new int[18][301];
	
	public static void compute(){
		for(int i=1; i<18; i++){
			for(int j=0; j<301; j++){
				if(i==1 || j==0){
					w[i][j] = 1;
				}
				else{
					w[i][j] = 0;
				}
			}
		}
		
		for(int i=2; i<18; i++){
			for(int j=1; j<301; j++){
				for(int k=0; j-k*i*i>=0; k++){
					w[i][j] += w[i-1][j-k*i*i];
				}
			}
		}
	}
	
	/**
	 * @param args
	 */
	public static void main(String[] args) {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String str = "";
		int n;
		compute();
		try {
			while(!(str = br.readLine()).equalsIgnoreCase("0")){
				n = Integer.parseInt(str);
				System.out.println(w[17][n]);
			}
		} catch (Exception e) {
			// TODO Auto-generated catch block
			e.printStackTrace();
		}
	}

}

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics